RSA Governance & Lifecycle Service Incident NAGL03

Incident Report for Governance and Lifecycle

Postmortem

Summery:

RSA was going through a scheduled maintenance window where the window took longer for the above environment. The time it took to complete the upgrade on the above environment exceeded 1 hours and 40 minutes

Root Cause:

The primary root cause was due to additional updates this instances required that took longer than anticipated. During the upgrade we ran into a 3rd party package that was not deployed properly which required us to upgrade more components to keep the environment in full alignment

Key Takeaways:

  • We’ve decided to modify our timelines during maintneance windows to account for 3rd party packages errors as we run into them
  • We’ve added more awareness points for maintenance windows
Posted Nov 19, 2025 - 17:37 UTC

Resolved

After monitoring the fix, RSA SaaS Operations has determined that the incident affecting RSA Governance & Lifecycle has been resolved.

RSA will post a root cause analysis as soon as it is available.
Posted Nov 08, 2025 - 10:30 UTC